0

I've been noticing that my buffer number increases really fast without me even using them. I rely on buffers quite a lot to switch between files, and it's really annoying when I open a second file and it's loaded into buffer 603.

I finally tracked down the issue to coc-pyright. When I disable the plugin, the buffers behave as I expect. I can't figure out why this plugin is increasing the buffers so quickly, but it seems like every time there's a window of information displayed, it uses and destroys a buffer to do so. Is there any way to avoid this behavior?

I'm using nvim 0.7.2.

3
  • sounds like you already found out the culprit. In that case, please create an issue at the plugins issue tracker Mar 27, 2023 at 7:43
  • @ChristianBrabandt that does sound like the obvious thing to do now. Not sure what I was thinking. I guess I just assumed there is some random Vim setting like :set disablehiddenbuffers=4 that I had set wrong.
    – jmbeck
    Mar 29, 2023 at 17:32
  • Submitted here: github.com/fannheyward/coc-pyright/issues/905
    – jmbeck
    Mar 29, 2023 at 17:42

1 Answer 1

0

I submitted the issue to the coc-pyright project: https://github.com/fannheyward/coc-pyright/issues/905

Hopefully an answer is given there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.