-1

I'm using Dracula colorscheme without anything in .vimrc

byte/int/void has background highlight, how can I disable it ?

Update:

  • removing hi! link Type DraculaCyanItalic worked
1
  • 2
    It would be good to change the Title to be a question and for it to be much more specific (so that in the future, other people will recognize this question as being the same as the one they have). ¶ It would also be good to move the Update into a real answer and then to accept your own answer with the check mark (so that people will know that the question has been answered already, and that it has a good answer). ¶ The point of these sites isn't so much to help the questioners with a one-time problem as it is to provide help for years to come to many other people with a similar problem. Mar 20, 2023 at 13:43

1 Answer 1

1

Dracula maintainer here. We have a number of similar issues on the GitHub repository.

In nearly all cases, the solution is to :let g:dracula_italic = 0 prior to loading the colorscheme (why? your terminal probably doesn't support italics, or isn't configured for them correctly—see :help dracula). How do I know this is the problem? The Type highlight is linked to DraculaCyanItalic, and sometimes misconfigured italics show up as "reverse" highlighting. The name and attributes of DraculaCyanItalic make me check the section of the doc about italics and disable them (if I don't want or cannot use them).

Others argue that the default should not be italics; but, in the spirit of the Dracula theme, we think italics are part of the colorscheme, so we've enabled them by default.

We (the maintainers and community) are happy to discuss specific issues at further length on our GitHub: https://github.com/dracula/vim.

3
  • No. Vim doesn't know how to deal with italics properly so the proper solution would for you to set that variable to 0 by default and let the user decide to enable italics or not. By the way, your doc explains nothing about OP's issue.
    – romainl
    Mar 21, 2023 at 14:14
  • @romainl This probably isn't the best place for that discussion. You disagree with the way the theme handles italics and such—fine, do it differently in your schemes. But the combative attitude that everyone else is wrong just for doing it differently is… unhelpful.
    – D. Ben Knoble
    Mar 21, 2023 at 14:31
  • "Misconfigured italics" is a nice way to shift the blame.
    – romainl
    Mar 21, 2023 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.