I just built neovim from source for the first time on linux (Pop!_OS 22.04 LTS x86_64), and I got stuck for a while on something silly.

In the Build prerequisites I saw that CMake was (of course) required, so I pip installed it as suggested, and it was also listed in the apt install command for Ubuntu / Debian requirements. At first I thought "I just installed cmake with pip so I don't need to install it again", but it turns out I was wrong because I was unable to run make install successfully until I ran sudo apt install cmake.

The error was cmake: not found at step build/.ran-deps-cmake, although cmake was already installed (cmake --version worked as expected).

Is there a reason for that? Did I miss something obvious?

  • Probably an issue of PATH and searching for the command. I suggest discussing with NeoVim maintainers on GitHub.
    – D. Ben Knoble
    Mar 11 at 14:19
  • Alright, thank you for you feedback, I will open an issue on Github. I wanted to ask here first in case I had missed something but I guess it might actually be a minor issue.
    – bluthej
    Mar 12 at 17:32
  • Related: vi.stackexchange.com/q/37475/10604
    – D. Ben Knoble
    Mar 14 at 15:36


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.