0

As you can see in both the vimrc.plug and vim.rc files they both seem to be working in terms of gruvbox. I have syntax on, but when I type Vim into terminal and start typing or open a specific file all the text comes back in that peach color.

Is there something I have configured wrong or is there something I need to input into Vim to make it work?

that is the vimrc.plug file

that is the vim.rc

5
  • when i typed :colorscheme in vim it says gruvbox but still only getting the peach characters no red, green or anything else Mar 10, 2023 at 1:59
  • Could you tell us what is the filetype of the buffer where the colonization seems not to be working (what is the result of the command :set ft??) Mar 10, 2023 at 5:24
  • i set ft=python and that worked, but for something like cpp it did nothing Mar 10, 2023 at 5:44
  • For a c++ file you have to do: set ft=cpp. If it doesn't give the color you want a screenshot would help to identify where the problem lay. Mar 10, 2023 at 5:52
  • 1
    i think i got the problem fixed setting the ft worked for some but i solved the problem regarding cpp thank you for your help once again i truly do appreciate it very much Mar 10, 2023 at 5:58

1 Answer 1

0

The colonization depends of the file type. If you edit a Python script the keywords will be in a special color, the same for javascript but for a different set of keywords.

Vim automatically set the filetype looking at the file extension for most file but you can also set it manually with the command:

:set ft=python
1
  • 1
    ty for your help i appreciate it Mar 10, 2023 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.