2

This question already has an answer here:

In the last week my vim has started to exit insert mode when I type alt + 3.

I have changed my theme to tomorrow night, but other than that no updates or changes to .vimrc.

Any ideas what could be causing this? I wouldn't have thought a colorscheme could do this.

marked as duplicate by Martin Tournoij Jul 30 '15 at 10:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    You probably updated your terminal emulator to send the escape key on Alt. See: How to map Alt key? and :help :map-alt-keys – Martin Tournoij Jul 30 '15 at 9:49
  • You could add your solution to the other question as an answer, if it's different from the existing answers so that people with the same problem are able to find it :-) – Martin Tournoij Jul 30 '15 at 10:58
  • Yea so my issue was slightly different, I needed to update my terminal settings to disable 'Use Option as Meta Key' which had been enabled somehow. I just happened to get to that solution through :help :map-alt-keys – Guy Jul 30 '15 at 11:02
  • 1
    That's exactly the same solution as the OP used in the other question ;-) – Martin Tournoij Jul 30 '15 at 12:12
  • haha, sure is! Saw the top voted comment not the accepted answer. Cheers! – Guy Jul 30 '15 at 12:13