0

I am struggling to enable the features advertised on https://nvchad.netlify.app/features. Upon installation, we only get basic features such as tabs and command bar, as per my experience and what I see from the tutorials. I tried using require in the init.lua but it doesn't seem to work.

Here's my init.lua after the install process from the docs:

vim.defer_fn(function()
  pcall(require, "impatient")
end, 0)

require "core"
require "core.options"

-- setup packer + plugins
local fn = vim.fn
local install_path = fn.stdpath "data" .. "/site/pack/packer/opt/packer.nvim"

if fn.empty(fn.glob(install_path)) > 0 then
  vim.api.nvim_set_hl(0, "NormalFloat", { bg = "#1e222a" })
  print "Cloning packer .."
  fn.system { "git", "clone", "--depth", "1", "https://github.com/wbthomason/packer.nvim", install_path }

  -- install plugins + compile their configs
  vim.cmd "packadd packer.nvim"
  require "plugins"
  vim.cmd "PackerSync"

  -- install binaries from mason.nvim & tsparsers
  vim.api.nvim_create_autocmd("User", {
    pattern = "PackerComplete",
    callback = function()
      vim.cmd "bw | silent! MasonInstallAll" -- close packer window
      require("packer").loader "nvim-treesitter"
    end,
  })
end

pcall(require, "custom")

require("core.utils").load_mappings()
6
  • 1
    Did you follow the installation steps? What is not working? Could give us your input,, the current behavior and the expected behavior. It will help to understand what is not working and where you are blocked? Feb 18, 2023 at 17:44
  • Yes I followed the installation process. It's my first time using neovim so unsure what I should have expected but I seem to miss all the features like for example the nvim-tree Feb 18, 2023 at 17:46
  • my experience was like in this video: youtu.be/ETIUU9wxmK0 Feb 18, 2023 at 17:48
  • 1
    Nice video:-) what I mean is could you tell us what you type in Neovim, what you get (a screen shot may help) and what you would like to get (a anoted picture could help) :-) Feb 18, 2023 at 17:59
  • I'm sorry to insist but without list your actions and resulting screenshots we have no way to know what goes wrong :-/ and it is very difficult to help you. Feb 18, 2023 at 19:24

2 Answers 2

2

NvChad rely on ~\AppData\Local\nvim\init.lua in particular you can't have a init.vim in the ~\AppData\Local\nvim folder.

To install NvChad you have to replace the full content of ~\AppData\Local\nvim by the VvChad content (in particular the init.lua and the lua folder)

To toggle NvimTree you have to use the :NvimTreeToggle command or with the NvChad shortcut Ctrl-n:

enter image description here

To display the dashboard the command should be :Alpha but I fail to make it working on my machine (maybe you have the same problem).

2
  • 1
    it says 'not an editor command :Alpha' Feb 19, 2023 at 19:17
  • 1
    I have the same problem. I'm not sure it is working on Windows. I noticed the it depend on base64 that fail to load because of local problems (run :checkhealth to see the problem) if I define LC_ALL I can solve the checkhealth and the installation of alpha but it is still not working. I'm stuck too :-) Feb 19, 2023 at 19:24
-1

OK so I was basically trying to setup dashboard-vim and nvim-tree to maybe show on launch and other common things. Apparently there's no preset from NVChad.

2
  • 2
    If you want to clarify your question the best is to edit your question. The answer are supposed to be answers ;-) Feb 18, 2023 at 19:22
  • 2
    perhaps this is answering the question by saying “these are not features of NvChad, so I did nothing wrong but my expectations were wrong”? If that’s the case, an edit to be more explicit would be helpful.
    – D. Ben Knoble
    Feb 19, 2023 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.