2

I am in Windows 11. I have downloaded and installed all the fonts 'CascadiaCode'. I have tried to add some thing like vim.g.guifont="CascadiaCode" to my init.lua but can't figure it out.

1 Answer 1

4

I would do:

vim.opt.guifont='CascadiaCode'

But If you want the Nerd version of it you have to install it and do:

vim.opt.guifont='CaskaydiaCove NFM'

Remark: Because 'Cascadia` is a Microsoft reserved name the NerdFont had to adapt the name.

To determine the font that Neovim accept you can use the Vim command: :set guifont=*. It will prompt you dialog:

enter image description here

You can select the font you want.

Then you can use the following command to know what is the associated font string to use for you setting:

:set guifont?

enter image description here

1
  • Did you managed to have the font installed and used in Neovim? Feb 18, 2023 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.