0

I'm currently getting an error whenever I open an Apex file locally with neovim. Has anyone come across this error before or have any guidance on how to solve it?

Here is the error:

Error detected while processing function <SNR>91_NetrwSplit[85]..<SNR>91_NetrwBrowseChgDir[197]..BufReadPost Autocommands for "*.cls"..FileType Autocommands for "*"..function <SNR>1_LoadFTPlugin[17]..script /Users/john.doe/code/opensource/dotfiles-1/.vi
m/plugged/vim-force.com/ftplugin/apexcode.vim[23]../Users/john.doe/code/opensource/dotfiles-1/.vim/plugged/vim-force.com/apex-plugin/apexToolingAsync.vim[14]..function <SNR>91_NetrwSplit[85]..<SNR>91_NetrwBrowseChgDir[197]..BufReadPost Autocommands for
"*.cls"..FileType Autocommands for "*"..function <SNR>1_LoadFTPlugin[17]..script /Users/john.doe/code/opensource/dotfiles-1/.vim/plugged/vim-force.com/ftplugin/apexcode.vim[23]../Users/john.doe/code/opensource/dotfiles-1/.vim/plugged/vim-force.com/ape
x-plugin/apexToolingAsync.vim:
line   14:
E605: Exception not caught: Vim version with '+job' feature is required

This is my vim setup. I let my neovim source my vim configs by doing this inse .config/nvim/init.vim :

set runtimepath+=~/.vim
set packpath+=~/.vim
source ~/.vimrc

This is my neovim version information

brew info neovim
==> neovim: stable 0.8.3 (bottled), HEAD
Ambitious Vim-fork focused on extensibility and agility
https://neovim.io/
/opt/homebrew/Cellar/neovim/0.8.3 (1,674 files, 25.0MB) *
  Poured from bottle on 2023-02-14 at 11:14:08
From: https://github.com/Homebrew/homebrew-core/blob/HEAD/Formula/neovim.rb
License: Apache-2.0
==> Dependencies
Build: cmake ✘, luarocks ✘, pkg-config ✔
Required: gettext ✔, libtermkey ✔, libuv ✔, libvterm ✔, luajit ✔, luv ✔, msgpack ✔, tree-sitter ✔, unibilium ✔
==> Options
--HEAD
    Install HEAD version
==> Analytics
install: 69,433 (30 days), 195,386 (90 days), 602,154 (365 days)
install-on-request: 69,110 (30 days), 194,460 (90 days), 599,512 (365 days)
build-error: 94 (30 days)

When I run :checkhealth these are the only warnings I see and they do not appear to be related:

29 ## Python 3 provider (optional)
30   - WARNING: No Python executable found that can `import neovim`. Using the first available executable for diagnostics.
31   - WARNING: Could not load Python 3:
32     /usr/bin/python3 does not have the "neovim" module.
33     python3.10 not found in search path or not executable.
34     python3.9 not found in search path or not executable.
35     python3.8 not found in search path or not executable.
36     python3.7 not found in search path or not executable.
37     python not found in search path or not executable.
38     - ADVICE:
39       - See :help provider-python for more information.
40       - You may disable this provider (and warning) by adding `let g:loaded_python3_provider = 0` to your init.vim
41   - INFO: Executable: Not found
...
    46 ## Ruby provider (optional)
    47   - INFO: Ruby: ruby 2.6.10p210 (2022-04-12 revision 67958) [universal.arm64e-darwin22]
    48   - WARNING: `neovim-ruby-host` not found.
    49     - ADVICE:
    50       - Run `gem install neovim` to ensure the neovim RubyGem is installed.
    51       - Run `gem environment` to ensure the gem bin directory is in $PATH.
    52       - If you are using rvm/rbenv/chruby, try "rehashing".
    53       - See :help g:ruby_host_prog for non-standard gem installations.
    54       - You may disable this provider (and warning) by adding `let g:loaded_ruby_provider = 0` to your init.vim
    55
    56 ## Node.js provider (optional)
    57   - INFO: Node.js: v14.21.2
    58   - WARNING: Missing "neovim" npm (or yarn, pnpm) package.
    59     - ADVICE:
    60       - Run in shell: npm install -g neovim
    61       - Run in shell (if you use yarn): yarn global add neovim
    62       - Run in shell (if you use pnpm): pnpm install -g neovim
    63       - You may disable this provider (and warning) by adding `let g:loaded_node_provider = 0` to your init.vim
    64
    65 ## Perl provider (optional)
    66   - WARNING: "Neovim::Ext" cpan module is not installed
    67     - ADVICE:
    68       - See :help provider-perl for more information.
    69       - You may disable this provider (and warning) by adding `let g:loaded_perl_provider = 0` to your init.vim

1 Answer 1

1

Looking at the error it seems that the vim-force.com plugin that you are using requires a version of Vim / Neovim compiled with the job and channel features.

Here is excerpt of the WebSite

Installation/System requirements

Before vim-force.com plugin can be used the following requirements must be met:

  1. Vim version 7.4 (with job & channel support) or later, with :set nocompatible

It seems that your version doesn't have it.

To verify that you can type the following commands:

:echo has('job')
:echo has('channel')
4
  • These commands: :echo has('job') and :echo has('channel') return 1 for me in my vim editor but they return 0 for me in my neovim editor. Do you have any guidance on how I should / could install job and channel in my neovim editor? My vim version is 9.0
    – robskrob
    Feb 14, 2023 at 22:39
  • 1
    Unfortunately you can't just installjob and chanel. You have either to find a distribution of Neovim that has these flags or compile it yourself with these them. Feb 14, 2023 at 23:23
  • thank you very much for helping me. I'll try to find a neovim distribution with Job and Channel. I'll also look into compiling neovim myself with those dependencies.
    – robskrob
    Feb 15, 2023 at 15:03
  • 1
    Thanks for the feedback if the solution fit don't forget to validate it using the v button next to the arrow voting button it help the question to rest ;-) Feb 15, 2023 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.