2

I have the Snipmate plugin in my .vimrc, but when I launch Vim, I get this error.

How can I fix it?

Here's what I currently have:

Bundle 'garbas/vim-snipmate'
4
  • FWIW, the original snipMate still works well and doesn't exhibit that issue.
    – romainl
    Commented Mar 5, 2023 at 23:29
  • @romainl how do you find/use "oroginal snipMate"? Commented Mar 6, 2023 at 13:09
  • You go to the GitHub page of the fork that you are using and you click on the "forked from" link and then you install and use it like the fork.
    – romainl
    Commented Mar 6, 2023 at 14:18
  • Was having the same problem...see below.
    – rixter
    Commented Jun 9, 2023 at 20:40

1 Answer 1

0

Add this line to .vimrc and restart vim, should fix the problem!

let g:snipMate = { 'snippet_version' : 1 }
4
  • Welcome to Vim :-) If you solution solves your problem may be could you accept it using the v green button next to the arrow voting buttons. It allow the question to rest :-) Commented Mar 6, 2023 at 8:04
  • @VivianDeSmedt I suppose I was waiting to see if anyone else found this answer useful, and / or provided a better answer. Perhaps some upvotes would build confidence. Commented Mar 6, 2023 at 13:11
  • I understand. If you are still waiting then feel free to let the question open that is the purpose :-) Commented Mar 6, 2023 at 13:22
  • 1
    Yep; lacostenycoder's fix worked for me...thanks!
    – rixter
    Commented Jun 9, 2023 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.