1

When auto-completing with neovim's LSP, whenever selecting a menu entry from the auto-complete list a scracth/preview buffer is created, even if empty:

enter image description here

How can I disable these buffers specifically for auto-completion ?

I'm aware of previewheight; setting it to 0 doesn't seem to have any effect, and even if it would, it would disable the preview buffer everywhere whereas I just want it disabled for auto-completion.

2
  • Try :help 'completeopt', though IDK if NeoVim baked in the preview flag there or not.
    – D. Ben Knoble
    Jan 31, 2023 at 15:09
  • @D.BenKnoble yep, completeopt exists and defaults to menu,preview; setting it to menu fixes the issue; if you make that into an answer i'll gladly accept it Feb 1, 2023 at 4:47

1 Answer 1

2

You should be able to use :set completeopt-=preview to remove this behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.