3

When I set vim.o.cmdheight=0 in neovim, then use macros. The recording @a messages are lost.

Aside for reverting back to vim.o.cmdheight=1, how can I display these messages in lualine?

vim.o.cmdheight=1 with a recording ongoing

Environment:

NVIM v0.8.2
Build type: RelWithDebInfo
LuaJIT 2.1.0-beta3
Compiled by runneradmin@fv-az28-353
+ lualine
3

1 Answer 1

3

You can use two simple autocmd if you're using lua configs

vim.cmd [[ autocmd RecordingEnter * set cmdheight=1 ]]
vim.cmd [[ autocmd RecordingLeave * set cmdheight=0 ]]

This will automatically enable cmdheight=1 when starting recording and when you stop it will take you back to the cmdheight=0. This is the workaround I'm using on my setup until they fix this bug. Tested on NVIM v0.9.0.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.