0

my nmap returns the following two lines among other things:

n  bh          * <Lua 5: vim/_editor.lua:344>
n  bl          * <Lua 4: vim/_editor.lua:344>

I dont want those mappings because they interfere with the b command. However I cannot locate this file. Any help? My plugins using vim plug are the following.

local Plug = vim.fn['plug#']
vim.call('plug#begin')
-- Snippets support
Plug ('L3MON4D3/LuaSnip', {tag='v1.1.0'})

Plug ('https://github.com/vim-latex/vim-latex.git', {tag='v1.10.0'})

--nvim api Autocompletion. Must be before lspconfig
Plug ('folke/neodev.nvim', {tag='v2.0.0'})

Plug ('https://github.com/neovim/nvim-lspconfig', {tag='v0.1.5'})

--Plugins for debugging
Plug ('mfussenegger/nvim-dap', {tag='0.4.0'})
Plug ('rcarriga/nvim-dap-ui', {tag='v2.6.0'})




--Plugins for code completion. We use the cmp plugin. This also requires completion
--sources. For now we only use the lsp source
Plug 'hrsh7th/cmp-nvim-lsp' -- Source for internal nvim lua completion
Plug 'hrsh7th/cmp-buffer' -- Cmp source buffer
Plug 'onsails/lspkind.nvim' -- Formating of completion sources
Plug 'hrsh7th/cmp-nvim-lsp-signature-help' -- Signature help from lsp
Plug 'saadparwaiz1/cmp_luasnip'
Plug 'hrsh7th/nvim-cmp' -- Autocompletion engine

-- Tree Sitter
Plug ('nvim-treesitter/nvim-treesitter',{['do'] = vim.fn[':TSUpdate'], tag = 'v0.8.1'})
Plug 'nvim-treesitter/playground'

-- Telescope dependencies and telescope
Plug ('nvim-lua/plenary.nvim', {tag='v0.1.2'})
Plug ('nvim-telescope/telescope.nvim',{tag='0.1.1'})


-- Tree viewer plugin. Configured automatically through after/plugin/nvim-tree.lua file
Plug 'nvim-tree/nvim-tree.lua'

-- This is a local directory pointed like that since the plugin is already under
-- development.
Plug '~/source/repos/Solution.nvim'
Plug ("rebelot/kanagawa.nvim", {commit= '4c8d48726621a7f3998c7ed35b2c2535abc22def'})
vim.call('plug#end')

where is the vim/_editor.lua file?

1 Answer 1

0

You should be able to do the following.

  1. Check the :scriptnames command for the name of your sourced command and filter it using the :filter command for your desired name _editor.lua:
:filter /_editor.lua/  scriptnames
  25: ~/vim/_editor.lua

This gives you the number of the file that has been sourced in your current vim session.

You can then edit this file using:

:25scriptnames

You can then edit this file and disable your mappings.

3
  • Thank you for your reply. While this did not solve the issue it pointed to the use the verbose nmap command. And this pointed the builtin matchit plugin Jan 17 at 19:16
  • I doubt it. I maintain the matchit plugin and it does not contain your mappings Jan 18 at 8:21
  • You are correct. After scouring my configuration I seems that I had those defined in a lua file that was required my by config. I don't know why vim/_editor.lua was reported. After that the matchit definitions followed and I assumed that it was matchit. Jan 21 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.