1

I've followed the instructions at https://github.com/neoclide/coc-pairs to install the autopair extension for coc:

:CocInstall coc-pairs

After running this command, I get the following message:

Install finished                                                                                                                                                                                                                                                   │~
    - ✓ coc-pairs Move extension [email protected] to /Users/adamgyarmati/.config/coc/extensions/node_modules/coc-pairs

The extension shows up if I run :CocList extensions and the package is listed in .config/coc/extensions/package.json. However if I open any file and type ( or ", nothing happens, the parentheses / quotes aren't closed.

I've noticed that after installing the extension, if I run :CocConfig, none of the options mentioned in the documentation are there. I've tried manually adding "pairs.enableCharacters": ["(", "[", "{", "<", "'", "\""] but that didn't help either.

I'm using nvim v0.5.1 and I don't have any other autopair plugin installed (at least not that I know of).

Any idea what could cause this issue and how to debug it?

1 Answer 1

1
+50

I can reproduce the problem on:

  • Neovim 0.6.1
  • Neovim 0.7.0

It works on Neovim 0.8.0

It seems that you need a more recent version of Neovim: version >= 0.8

3
  • Thanks, I'll try this. I didn't find a version requirement for Neovim, the docs say Ensure your Vim version >= 8.0 using :version
    – adamgy
    Jan 9, 2023 at 17:14
  • 1
    Yepp, upgrading neovim worked, thanks! I was worried about upgrading but just ran brew upgrade neovim and nothing broke.
    – adamgy
    Jan 9, 2023 at 18:16
  • Thanks for the feedback :-) Jan 9, 2023 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.