1

I have a custom function and mapping:

nmap <C-m> :MyMake<CR>

This works as intendeded, the correct function is called etc. But it creates another mapping, running :nmap shows that CR is now mapped to :MyMake <CR> as well.

Any ideas on why this is?

3

<CR> stands for carriage return, and depending on your terminal settings, CtrlM gets you a carriage return. Consider using another key combination. See also:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.