0

I have the following in my configuration:

nnoremap µ iii
nnoremap ° ioo

I'm using gvim, on Windows 10, using an azerty keyboard (so µ is <S-*> and ° is <S-)).

The mappings work in vim8, but after upgrading to vim9, even though I can still see these mappings using

nnoremap µ
nnoremap °

Pressing µ or ° in normal mode triggers vim's bell instead of my mappings.

Did vim9 change something in that area?

2
  • Nothing related to what you are trying to do changed and your mappings work fine. Your problem is elsewhere.
    – romainl
    Nov 25 at 6:25
  • @romainl I have the uttermost respect for you, thank you for your input. I did try a lot of things elsewhere but to no avail. Vivan De Smedt's suggestion worked, so maybe there is a time component in the detection of the mapping. It might explain why on some computers it works (yours?) while on some others it does not (mine?) Nov 25 at 22:39

1 Answer 1

1

I believe Vim is not precise in the mapping, in particular you have to specify the key modifier and the resulting character.

I believe you should do with Vim-9:

nnoremap <S-°> iii
nnoremap <S-µ> ioo
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.