I could really use some help here...

I have just migrated my nvim setup to all Lua and changed some plugins.

I have added nvim-treesitter and tried a few themes. The themes change OK and get applied, but there's something off with the colors, and I have no idea why. I can't find any config which affects it.

It might not even be a Neovim problem because when I open nvim in Terminal instead of iTerm the background is just all yellow and highlighting doesn't seem to work (or is that because it doesn't support those colors?).

dotfiles: https://github.com/MrMatten/dotfiles

iTerm, tmux, nvim

packer, treesitter, oceanic-next enter image description here

enter image description here

  • Just convert back to non-lua configs. Why would you wanna fix something that's not broken? Leave what you already have as it is. Any future config you do, do it in Lua and just import it with :h lua-require from init.vim.
    – 3N4N
    Commented Nov 13, 2022 at 7:54
  • Kind of funny assumptions you have. 1. It didn't work as intended before, so in some ways it was broken, 2. many of the plugins I changed was because of deprecation, 3. I wanted an easier way of thinking about my config and wanted to try Lua, 4. I like messing around with it, so I also think it is fun
    – Mr Matten
    Commented Nov 13, 2022 at 9:01
  • > It didn't work as intended before. Sorry for assuming wrongly. Since you started with saying, "I've migrated ... to all Lua," it's natural to assume the problem you're facing is a result of this migration. If not, if the colorschemes don't work in VimL config, mentioning that in the OP will be helpful.
    – 3N4N
    Commented Nov 13, 2022 at 10:01
  • > 4. I like messing around with it, so I also think it is fun. Great. Then figure out the problem and the solution by yourself, maybe? More of a chance for you to "mess around."
    – 3N4N
    Commented Nov 13, 2022 at 10:02
  • I started almost from scratch so I don’t know if it works with regular vim setup. I wrote my question because 5 hours let no where so I hoped some nice person could help me 😅
    – Mr Matten
    Commented Nov 13, 2022 at 16:02

2 Answers 2


I hit the same issue when I have set termguicolors (vim.o.termguicolors = true). It can be fixed with set notermguicolors (vim.o.termguicolors = false).

  • With set termguicolors

    enter image description here

  • With set notermguicolors

    enter image description here


This ended up having nothing to do with a plugin or anything else Lua related.

iTerm2 was affecting the colorschemes even though I have tried with termguicolors on/off.

I have now changed to Alacritty to try something else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.