2

As title. With my current setup it looks like this:

But I only want it to use a single color. My current highlight setup:

:hi IndentBlanklineContextStart
IndentBlanklineContextStart xxx cterm=underline gui=underline guisp=#fb5e2a

And, what makes me confused is that this problem only occurs when my neovim is running inside a tmux session. If I run neovim directly without tmux session I got expected behaviour:

2
  • What's the value of echo $TERM (executed from bash) in outside and inside tmux?
    – 3N4N
    Oct 19, 2022 at 14:15
  • @kadekai: Thanks for your help :) The result of it inside/outside tmux are both alacritty. Not intended to do things in a rush but I also asked the same question on both tmux and alacritty's GitHub repos and got the answer. So hopefully this comment will save your time to help more people :) Oct 19, 2022 at 14:22

1 Answer 1

3

This answer will only be useful for those who also have this environment setup:

  • You use Alacritty as terminal simulator. (since it support coloring of underlines.)
  • Running neovim inside a tmux session.

When I tried to solve this problem I wasn't sure about the source of it. It turns out this is not related to vi/vim(so sorry about posting it here...), and we only need to add one line in tmux.conf:

set-option -ga terminal-features ",alacritty:usstyle"

If you want to read more context, this is the related issue on GitHub:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.