3

I'm on MacOS Big Sur. I have the latest Vim and Neovim installed via Homebrew.

Loading any source file with Vim works fine. But with nvim, I always greeted by this error:

Error detected while processing BufWinEnter Autocommands for "*"..function 104_Setup[6]..104_IndentLinesEnable[10]..104_SetConcealOption: line 8:

My complete init.vim is available here. A quick Google search led me to this, which suggested to me disable Yggdroot/indentLine plugin. Once the plugin is disabled, no error message appear.

But what if I still want to use the plugin? I found this hint:

You are setting g:indentLine_concealcursor in your .vimrc to an invalid option. g:indentLine_concealcursor must be set to a valid option value for 'concealcursor', see `:h 'concealcursor'

In my init.vim, there's:

let g:indentLine_concealcursor = 0

What's the proper value, then?

1
  • The default value is 'inc'. I would try a string maybe an empty string ''. Oct 9, 2022 at 17:06

1 Answer 1

5

I believe you should set the variable to a value that is compatible with the conceal option.

It should be a string that is a combination of n, v, i, c.

More information

:help 'concealcursor'
'concealcursor' 'cocu'  string (default: "")
            local to window
            {not available when compiled without the |+conceal|
            feature}
    Sets the modes in which text in the cursor line can also be concealed.
    When the current mode is listed then concealing happens just like in
    other lines.
      n     Normal mode
      v     Visual mode
      i     Insert mode
      c     Command line editing, for 'incsearch'

    'v' applies to all lines in the Visual area, not only the cursor.
    A useful value is "nc".  This is used in help files.  So long as you
    are moving around text is concealed, but when starting to insert text
    or selecting a Visual area the concealed text is displayed, so that
    you can see what you are doing.
    Keep in mind that the cursor position is not always where it's
    displayed.  E.g., when moving vertically it may change column.
1
  • 1
    Ah I see. let g:indentLine_concealcursor = 'nc' works fine. Thank you.
    – anta40
    Oct 9, 2022 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.