1

After quite some time of using Vim I wanted to switch to NeoVim and set it up with more IDE-like features. So I googled and took the first thing I found (LunarVim/nvim-basic-ide/), thinking I could change the few things I got used to with my old almost plain config. So far this has worked quite well.

But the one thing I can't seem to find is how to get back to the default behavior where the cursor doesn't jump to the next line. If I move with h to the beginning of a line I want it to stop there. Same for the end of a line and l. It's the default behavior for (Neo)Vim. Can someone please point me in the right direction?

0

1 Answer 1

2

This is controlled by the 'whichwrap' setting.

Try this:

" Remove h and l from 'whichwrap'
set whichwrap-=h,l

Or just:

" Use defaults
set whichwrap&

I'm not sure how you configure LunarVim not to fiddle with this setting. Try running :verbose set whichwrap? to find out exactly what's setting it.

As a worst case scenario, you could try reverting to the defaults at the end of startup:

augroup fix_whichwrap
  au!
  au VimEnter * set whichwrap&
augroup END

FWIW, I'd personally recommend against using something like LunarVim, for precisely the reason that you're experiencing: systems like this can break things in hard to track-down ways. Use whatever plugins make you more productive, but install them one at a time as and when you need them: don't install a bunch of things preemptively.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.