0

I recently set my vim status bar using this:

" set status line
set laststatus=2
set statusline=
set statusline+=%#StatusLineFile#
set statusline+=\ %F
set statusline+=%m
set statusline+=%=
set statusline+=%#StatusLineTail#
set statusline+=\ %y
set statusline+=\ %{&fileencoding?&fileencoding:&encoding}
set statusline+=\[%{&fileformat}\]
set statusline+=\ %p%%
set statusline+=\ %l:%c
set statusline+=\ 

in ~/.vimrc, it works well most of the time, but some times it does not work and shows the default status bar (white background and black text), here is the img: enter image description here as you can see, the latex log is using the default status bar instead of that in .vimrc, how can I fix the problem so that it is consistent?

1 Answer 1

2

This is called "quickfix window". Read :h quickfix.txt to get more info on it.

To disable quickfix custom status line you have to execute let g:qf_disable_statusline = 1 before opening it for the first time (or put this line into your vimrc, obviously).

Still remember that your "generic" status line may have a lesser value when applied to special windows/buffers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.