0

I've been user of YCM for years now. Recently discovered coc-vim and trying it out. Looks like it provides loads of additional features on top of what YCM has.

One thing that I can't figure out how to get to work is the default completion YCM had. E.g. when writing as bash script, YCM would automatically recommend completion suggestions while typing - e.g. function names.

nvim -version
NVIM v0.7.2
Build type: Release
LuaJIT 2.1.0-beta3
Compiled by [email protected]

Features: +acl +iconv +tui

How to enable this in vim-coc? Any other recommendations for someone coming from YCM as for configuration or useful reading material?

1
  • Do you still have the problem? How can you help you further? If one of the answer solves your problem maybe could you accept it using the v button next to the arrow voting buttons. I allow the question to rest :-) Jul 20, 2023 at 11:33

2 Answers 2

0

With Coc you have to install language support for the target language.

For bash one solution is to run the command:

:CocInstall coc-sh

It will install the sh language server

4
  • 1
    Did that. This is what I ran after installing coc: nvim +'CocInstall -sync coc-snippets coc-tsserver coc-json coc-html coc-css coc-pyright coc-sh' +qall
    – laur
    Aug 24, 2022 at 16:10
  • Did you ran the :CocInstall coc-sh within Vim? What is the result? Could you share a screenshot? Aug 24, 2022 at 16:52
  • 1
    Command above installs it within neovim, yes; screenshot of explicitly re-installing coc-sh: i.imgur.com/VevZiTf.jpg; relevant part from :checkhealth: i.imgur.com/acYmJYT.jpg
    – laur
    Aug 24, 2022 at 23:50
  • Thanks. With this you should get the completion. I have tested that I gat at least the function name defined in the script. Can you five us an example of you expect and what you get? Aug 25, 2022 at 3:01
0

Solved it by removing items from vimrc line-by-line. Mine had two issues:

  1. set wildmode
  2. set paste

First interferes with command tab completion, and the other disables the autocompletion UI. After both settings were removed, coc-vim started behaving as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.