0

I was playing around with setting columns and then turning wrap on&off.

The screenshot actually shows an empty buffer. To reproduce:set columns=80 number, make a huuuuge line of i-s and turn wrap on and off. With vim -u NONE as in the screenshot it felt it's a bit harder to reproduce than in my normally configured version but still happens. Any idea why? Is this a known bug or something that I can prevent?

enter image description here

5
  • I can reproduce with my regular vimrc, but not if I use the default settings with vim -Nu NONE, so it seems affected by some other setting, too. If you can make it reproduce with vim -Nu NONE you can file a bug on the Vim issue tracker. Aug 17, 2022 at 11:46
  • 1
    I don't follow. Is this an empty buffer or not (filled with is)? What version? What terminal? Aug 17, 2022 at 12:41
  • Terminal is kitty 0.25.0, vim is 9.0. The screenshot is an empty buffer AFTER I filled it with a ton of i-s (single line), flipped wrap a few times and then deleted the line.
    – fbence
    Aug 17, 2022 at 13:57
  • Didn't know about the -N option, but I'll check with that as well, and then maybe try to incrementally figure out if it is one of my settings.
    – fbence
    Aug 17, 2022 at 13:58
  • -N is set nocompatible; just gives you slightly more modern defaults for various settings that are not compatible with vi from 70s/80s. Aug 18, 2022 at 0:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.