1

I have set spelllang=en_us,ru_ru in my .vimrc, and when I enable spell check by typing :set spell, Vim shows me a pop-up window that says that the dictionary for the second language is not installed.

enter image description here

Yes, most of the time I don't have it installed, but I don't want to have this annoying pop-up window.

Is it possible to workaround this issue and simply avoid this window somehow?

2 Answers 2

3

The simples way to ignore this message is to globally ignore the SpellFileMissing autocommand:

:set eventignore=SpellFileMissing

See :h 'eventignore

3

:h spell-SpellFileMissing talks about how to handle your situation. There are basically two ways:

  1. Downloading spellfiles is done with a plugin. You can simply disable that plugin.

    let loaded_spellfile_plugin = 1
    
  2. Instead of using the plugin you can define a SpellFileMissing autocommand

    :au! SpellFileMissing * echo "Spell file for " . expand('<amatch>') . " not found."
    

Read through the help docs mentioned above for a better understanding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.