2

If I use the <tab> completion while typing in command mode, the full results listing will display above the commandline for just a moment, but then almost immediately disappear. If I hit tab again, the results will display, but only with the single line listing within the statusline, not in the "full" menu that showed before.

I've tried using :profile but after typing :colo <tab> to bring up the menu and then completing the profile commands, the resulting file is blank.

:profile start ~/profile.log | :profile func * | :profile file *
<do stuff>
:profile pause
:noautocmd qall!

Is there anything else I can use to see what may be happening in the background?

I also tried :verbose au, but that output doesn't seem related. (Or maybe it does show what I'm after and I'm not reading it properly?)

options.lua

wildmenu = true,
wildmode = "list:longest,list:full",

This does not happen when launching with nvim -u NONE so I suspect it's likely something on my end, either related to a plugin or to something in my config/keymaps/etc.

12
  • 2
    Did you remove your other settings? I'm running nvim -u NONE -c "set wildmenu | set wildmode=list:longest,list:full" and seems to be working fine: i.imgur.com/pJjhTkp.gif
    – r_31415
    Aug 5 at 21:51
  • 2
    It is certainly unusual. When you were bisecting your configuration file, did you prevent other files from loading. I ask this because you seem to have other files other than options.lua. You can also grep recursively and see if you have cmap, cnoremap, or autocommands that could be the real culprit. If that doesn't work, post a minimal, reproducible example (no plugins and only relevant settings enabled). I wasn't able to replicate this behavior in the latest neovim (v0.8.0-dev-784), by the way.
    – r_31415
    Aug 6 at 6:48
  • 2
    Got it! Turns out it's something related to lualine! Thank you so much for teaching me a bit more vim-fu for how to navigate these sorts of hiccups @r_31415 !
    – Spectator6
    Aug 6 at 12:51
  • 3
    @Spectator6 you need to fully close and re-open. :source executes commands in a file; you need (Neo)Vim to "forget" all of the current state. It sounds like you found the issue, so I'm going to close this
    – D. Ben Knoble
    Aug 6 at 16:49
  • 2
    No problem. I'm glad you figured it out. Actually, I found the bug causing this issue here: github.com/nvim-lualine/lualine.nvim/issues/781. I suppose this was opened by other user, right?
    – r_31415
    Aug 6 at 16:55

0

Browse other questions tagged or ask your own question.