3

When I'm nearing the right-hand side of my vim window, the vim-jedi's pop has some weird line-wrapping behavior:

simple vim window with line-wrapped vim-jedi popup

Is this normal behavior? How can I get the popup window to be shifted leftwards and appear all on one line?

  • Cannot reproduce with a simple [lots of spaces] import assert [newline and a lot of spaces] assert. (then completion starts). That was tested with the Konsole terminal emulator on KDE (Arch Linux), vim 7.4.738, jedi-vim 0.7.0-154-gbce599f. – Lekensteyn Jul 4 '15 at 9:08
  • did you noticed that your popup completion seems to be on two lines ? I see the 2, kwargs='hippos') on the line below (arg1, arg. – nobe4 Mar 10 '16 at 11:21
  • @nobe4, yes. that's what I meant by "line wrapping". I'm not sure it helps solve things though... – drs Mar 10 '16 at 16:25
  • can you check your textwidth and your wrap options ? – nobe4 Mar 10 '16 at 16:27
  • 1
    Have you tried to debug your vimrc file according to the steps here? Perhaps there is a specific setting (or combination of a few settings) or another plugin that's causing this. – Martin Tournoij Mar 11 '16 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.