0

Whenever I press and hold any arrow key (e.g. h, j, k or l) they appears on screen as such:

image

The same kind of thing happens whenever I accidentally scroll, where ^[OA are displayed if I scroll up and ^[OB displayed if I scroll down.

How do I fix this?

Thank you

OS: Debian 11

Vim version: 8.2

Ps: sorry if the tag is not relevant. I had to put one but have no idea as to which one to put in this case

5
  • 1
    Welcome to Vim :-). Your problem look like a terminal specific problem. Do you have everything right after hitting Ctrl-l for redraw? Can you tell us what is your OS and your version of Vim? Jul 12 at 13:42
  • 1
    You might also want to check the environment variable TERM (:echo $TERM in Vim) and the option 'term' (:set term? in Vim)
    – D. Ben Knoble
    Jul 12 at 14:34
  • Sorry for answering so late. I'm running vim 8.2 on Debian 11. Ctrl+l gets rid of all unwanted characters on screen (thanks!). :echo $TERM returns xterm-256color and :set term? returns term=xterm-256color. Thanks for your help
    – Some Guy
    Jul 13 at 17:03
  • In what terminal emulator?
    – D. Ben Knoble
    Jul 13 at 17:33
  • the terminal emulator is konsole
    – Some Guy
    Jul 19 at 7:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.