0

I use a keyboard layout designed for Spanish speakers and I've remapped hjkl to jklñ because those are the main home row keys. With hjkl I have to be constantly moving my hand to the left in order to move around in my file.

So what I want is to setup a command that uses <C-ñ>, but when I tried doing that, it just didn't work. It didn't do anything. Does anyone know what I could do?

4
  • Mapping Ctrl-x where x is not in a-z is nerver gurantee to work in Vim. I fear it will not work. Jul 11 at 19:28
  • 1
    you might be interested in the langmap or keymap options (also :help language-mapping, :help mbyte-keymap)
    – D. Ben Knoble
    Jul 11 at 19:38
  • One interesting experiment to do is to verify what are the codes sent to Vim when the Ctrl-ñ is sent. You can do that by typing in insert mode: Ctrl-v Ctrl-ñ. With that input you can map this sequence of code to the sequence you like (sometime it works ;-) ) Jul 12 at 6:59
  • Interesting, thanks for that info! The answer was sadly disappointing though, it just doesn't send any code to vim at all
    – Katie And
    Jul 13 at 3:46

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.