0

I recently switched to Neovim's new LSP setup instead of the old Vim-based language plugins and now I get this incredibly annoying comment "helper" behavior when I hit enter after a /** in e.g. typescript where a new line, a space, a tab, an asterisk and then another space are added for me.

I hate this. How do I disable it?

Image for reference (with whitespace characters enabled):

enter image description here

3
  • Please don't post images of text. Take a look at How to debug my vimrc to see if you can find the exact, minimal way to reproduce the problem.
    – D. Ben Knoble
    Commented Jul 5, 2022 at 15:24
  • This looks like the indent for your specific filetype sets it up like that; which filetype are you editing? And what does :verbose set indentexpr? show? Commented Jul 5, 2022 at 15:47
  • @D.BenKnoble Been on this site for over a decade, I'm aware of the rules. I posted an image in this case to show the whitespace characters, which otherwise wouldn't show up here. I also wrote out the description of the text directly before it, and explained why I showed an image.... Commented Jul 7, 2022 at 7:36

1 Answer 1

0

This may be an issue with your formatoptions option. Try executing :set formatoptions-=ro. See :help fo-table and :help formatoptions for more details on this option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.