3

I’m trying to use the Automatic LATEX Plugin for Vim (ATP), and found it has quite neat features. However, I do not like input abbreviations, so I tried to disable them using

let g:atp_no_env_maps=1
let g:atp_imap_define_greek_letters = 0
let g:atp_imap_define_math = 0
let g:atp_imap_define_math_misc = 0
let g:atp_imap_define_diacritics = 0
let g:atp_imap_define_fonts = 0
let g:atp_tab_map = 1

in my .vimrc. But that did not cut it, it seems. In particular, when I enter ' or ` or \s or \c, the cursor does not advance until I press the next key.

What is the recommended way to disable these imaps, but still have the <TAB> imap?

2

If nothing helps, you can always explicitly :unmap/:unabbreviate the keys in a filetype event autocommand or using the ftplugin/tex.vim file. That should make it work. Don't forget, that you probably need the <buffer> modifier for those commands.

But perhaps, you want to ask the author of that plugin directly. It seems, he will be better suited to answer this question.

Looking at the help, it seems :ToggleIMaps should at least partially get rid of the ` and ' mappings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.