2

I would like to test the new vertical wildmenu of Vim 9.

I read that set wildoptions=pum should provide it. But I'm not successful.

Is there another setting to set to get it?

2 Answers 2

4
  1. vim -Nu NONE
  2. :set wildmenu wildoptions=pum
  3. :e <tab>

enter image description here

3
  • Hi Maxim, is there a way to get the same menu using the <C-d> completion? Jul 2, 2022 at 16:27
  • 1
    @VivianDeSmedt I don't think so (as of today)
    – Maxim Kim
    Jul 2, 2022 at 16:30
  • 1
    @VivianDeSmedt You can use :set wildchar=<C-d> if you prefer to use <C-d> over <Tab>, although that will break Tab. Not sure how to have both; e.g. cnoremap <C-d> <Tab> doesn't work. Jul 3, 2022 at 15:24
1

You have to:

  1. enable wildmenu: :set wildmenu
  2. set wildoptions to pum: set wildoptions=pum
  3. trigger completion using tab instead of Ctrld
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.