3

when I use to autocomplete in neovim, I get two completion lists. The following screenshot was taken with an empty .nvimrc. Neovim with two completion lists

To reproduce: Open nvim, enter :e, tab <Tab> to get the (in this case) blue completion list, then tab <Tab> again to get the second interactive list.

I would like to disable the blue completion list, is that possible? I also noticed that vim does indeed only shows me the second list.

7

The yellow "interactive" list is called the "wildmenu". You can enable & disable this with the 'wildmenu' setting.

The 'wildmode' setting controls when to show this menu. If this contains the list keyword, it will list all possible completions.

You probably want to use set wildmode=full, but see :help wildmode for more options.

The defaults are:

wildmenu:

  • Vim: Off
  • NeoVim: On

wildmode:

  • Vim: full
  • NeoVim: list:longest,full

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.