0

Syntax highlighting within Telescope preview shows up better than inside neovim itself. From what I understand, the Telescope preview is based on what it would look like in an nvim buffer, so what am I missing?

I've tried the solution from this post by adding the following lines to my init.vim and sourcing but they have had no effect.

lua <<EOF
require'nvim-treesitter.configs'.setup {
  highlight = {
    enable = true,
  },
}
EOF

syntax highlighting in Telescope preview

syntax highlighting outside Telescope preview

1 Answer 1

0

Never mind, I discovered this plugin

https://github.com/nathom/filetype.nvim#customization

and set my filetype for .launch files to be .xml which fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.