I have vim 8.2 installed on my Debian machine and when I open it in a gnome-terminal it has a solid non-blinking box as a cursor.
But when I open a "pure" terminal with ctrl+alt+F3 and open vim I get a blinking underscore as a cursor.
The same thing happens when I open vim 8.2 on my Arch Linux machine that does not have a desktop environment.

Does someone know why that happens?
I mean it is the same vim installation. Is gnome-terminal opening a graphical form of vim? gvim? That would be strange because it is not really graphical as it is all in a terminal and I can't use a mouse in gnome-terminal...

Also using commands like these to change the cursor don't do anything in a pure linux terminal:

:set guicursor=n-v-c:block-Cursor

1 Answer 1

  1. When you run Vim in a terminal emulator, it is the terminal emulator that controls the cursor shape and color.

    Since you are using different terminal emulators it shouldn't be surprising to have different cursor shapes or colors.

    Note that it is possible to affect the cursor's shape from within Vim but a) it is not done by default, and b) the exact way depends on your terminal emulator.

  2. As its name and documentation suggest, :help 'guicursor' only affects the GUI version of Vim. Setting the option in the TUI version has no effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.