2

I upgraded my mac to Catalina and now the vim syntax looks all off to me. I am sure that strings used to be red, and I think that def used to be turquoise and import was pink. Is there a simple way for me to change the default syntax coloring so that strings are displayed in red text?

enter image description here

For reference, here is my .vimrc file:

:map <S-s><S-s> :w<CR> 
set undofile
set undodir=/Users/kilojoules/.vim/

syntax on
execute pathogen#infect()

autocmd BufReadPost *
     \ if line("'\"") > 0 && line("'\"") <= line("$") |
     \   exe "normal! g`\"" |
     \ endif
set undofile                " Save undo's after file closes
set undodir=$HOME/.vim/undo " where to save undo histories
3
  • It's quite possible the background detection improved (or catalina's terminal better signaled its background) and so the default colorscheme went from behaving like :set bg=light to :set bg=dark. You could possibly even test if that's the case by setting the background and seeing what happens.
    – D. Ben Knoble
    Commented May 17, 2022 at 20:53
  • @D.BenKnoble This was exactly the issue thanks for pointing that out
    – kilojoules
    Commented May 21, 2022 at 19:19
  • 1
    please add an answer if you have one that solved your problem!
    – D. Ben Knoble
    Commented May 22, 2022 at 16:43

2 Answers 2

1

You can choose a colorscheme and set it in your ~/.vimrc

colorscheme <colorscheme_name>

1

I completely understand your problem. The issue is that the new system is better at detecting the background as being dark. Simply add

set bg=light

to your .vimrc file my friend. That should restore your color scheme to the one you know and love.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.