0

I'm on Mac Neovim. When I type :term, I am greeted by this: enter image description here

This poses some issues; For example when I run a command, it also colors the output; I don't want this to happen. Is there some way to change the terminal colors or completely disable it?

Note 1: Setting termguicolors didn't fix this

Note 2: The normal terminal (non vim one) color is different, and ok.

EDIT: Looks like this issue extends beyond the terminal: enter image description here As you can see here, stuff like nerdtree and all are getting underlined and colored. This is not due to the colorscheme; The same happens with the default colorscheme. How do I fix all this?

9
  • are you talking about your prompt colors? Or where exactly? If for the prompt, than configure your prompt to not emit colors when run from neovim terminal Apr 17 at 14:43
  • Could be related to :help g:terminal_ansi_colors or the particular terminal emulator and $TERM. You can sometimes request no colors by setting the environment variable NO_COLOR
    – D. Ben Knoble
    Apr 17 at 15:58
  • @ChristianBrabandt -- The colors when I'm editing a file in neovim are fine. The colors when I'm working in the terminal outside of nvim are fine. The terminal inside of vim (when I type :term) is the problem and the screenshot above.
    – obr
    Apr 17 at 16:22
  • I'm not sure, but this might have something to do with my colorscheme (palenight)...
    – obr
    Apr 17 at 16:23
  • I just tested out another color scheme, and the issue was still there, albeit with different colors.
    – obr
    Apr 17 at 16:42

1 Answer 1

1

I finally got it! It was the spell check in the terminal causing the issue! I added this to my config:

autocmd TermOpen * setlocal nospell

Now it doesn't highlight in the terminal.

1
  • @D.BenKnoble -- Yep, probably. Fixed it.
    – obr
    Apr 17 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.