0

I've been mapping all my telescope commands to tab-<key>, which is quite convenient. However I've noticed that its broken the default shortcut for navigating forwards through the jump list, which is <C-i>.

Is there a way around this? Ive found similar questions like How to map <C-i> separate from <Tab>? , but these are not nvim specific.

2
  • Just because it's not specific to neovim doesn't mean it won't work—did you try the linked question? The order of operations there appears to matter. Note also that mapping <Tab>a doesn't break <Tab>, but depending on your settings you may have to wait a few seconds before it takes effect (vim has to wait to know whether to trigger your mapping or if there's nothing else coming; alternately, <Tab><some key that doesn't have a tab-mapping> would happen faster, but you have to deal with the effects of the extra key—<C-g> might be a good option there.)
    – D. Ben Knoble
    Apr 15, 2022 at 15:58
  • Ah, sorry I was ambiguous. I have tried the solutions suggested to that question, paying attention to the order of operations as suggested.
    – john
    Apr 15, 2022 at 17:27

1 Answer 1

0

Here was how I was able to achieve this.

-- Disable tab for jumping, must us <C-I> instead
vim.keymap.set("n", "<C-I>", "<C-I>")
vim.keymap.set("n", "<Tab>", "<Nop>")

Details here https://github.com/neovim/neovim/issues/14090#issuecomment-1113090354

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.