1

My terminal can and does sound a bell for different actions such as hitting tab or running >printf '\7'. My Vim is configured to sound a bell for error scenarios such as the command ggk.

However, vim-terminal does not sound the terminal bell when I hit tab (in insert mode) or run >printf '\7'.

Is there a way to enable the bell in Vim terminal?

1 Answer 1

0

I believe the following options are related to error bells:

  • errorbells
  • visualbell
  • belloff

I also believe vim defaults to no noisiness, so you have to explicitly turn them on. Try :set errorbellsand see if that gives you what you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.