In this display, what does the "xxx" mean?

:hi Search
Search         xxx term=reverse ctermbg=11 guibg=Yellow

On my display (cygwin/xterm), Search displays as black on black.

If I do this, nothing changes

:hi Search term=NONE

Apparently, "Search" is not (no longer?) the correct syntax name for highlighted searches.

How can I see what colorscheme "default" selects? In /usr/share/vim/*/colors, it's a complicated reference.

  • could also be IncSearch highlighting. The xxx shows you how that will be colored in your terminal. Might also be a terminal configuration issue. Mar 9, 2022 at 9:48
  • "The xxx shows you how that will be colored in your terminal.": do you mean it has no syntactic purpose, it's just displayed as an illustration?
    – n952162
    Mar 9, 2022 at 10:29
  • Yes @n952162; it's just a piece of example text. Mar 9, 2022 at 15:58
  • And Search is the correct highlight group. :hi Search term=NONE only clears the term property, but not ctermbg or guibg; to fully clear it use :hi clear Search. Not sure why the background appears as black; I guess that's probably because of ctermbg=11? Try using a different number/colour there, maybe your terminal doesn't support the "bright" colours 9-15? You can also try with something like printf '\x1b[48;5;11m yellow bg \x1b[0m\n' to check it shows up correctly in your terminal. Also check the t_Co setting in Vim; what's that set to? Mar 9, 2022 at 16:03
  • The printf command printed out " yellow bg ", black fg, yellow bg, as expected.
    – n952162
    Mar 9, 2022 at 16:51

1 Answer 1


xxx is supposed to be the preview of your current highlight settings: cyano highlight background

So when i do: :highlight Search ctermbg=yellow, i get:

yellow highlight background

Even though this does not help you with your Problem, i hope it explanes the purpose of xxx.

Best regards

  • 1
    :-) ;-( yeah, thank you, now I can stop searching for the hidden keyword solution to my highlighting problem ... ;-)
    – n952162
    Mar 9, 2022 at 12:23
  • @n952162 Please accept this answer (by clicking on the checkmark next to the answer).
    – r_31415
    Aug 7, 2022 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.