0

I have a limited OS, and compiling vim. How to disable libsodium lib?

I installed libsodium18 and libsodium-dev and libsodium-dbg, but I get the following errors:

error: 'crypto_pwhash_argon2id_SALTBYTES' undeclared here (not in function)
2
  • Probably configure without sodium or edit the makefile
    – D. Ben Knoble
    Feb 20, 2022 at 13:32
  • Can you provide more information? What version is libsodium-dev? How do you compile (e.g. what configure flags did you use)? Can you show a logfile of configure and compile? Feb 20, 2022 at 22:02

1 Answer 1

2

When configuring vim before building, disable libsodium

./configure   ...    --disable-libsodium    ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.