0

I wanted lightspeed-like features in Vim (without having to install Neovim).

I installed vim-sneak and followed the directions to enable "label-mode":

let g:sneak#label = 1

But when invoking sneak, labels don't show up and I still have to use ; and , to move between matches.

Why isn't vim-sneak's label-mode working, even though I enabled it according to the directions?

1 Answer 1

0

I figured out the answer.

In the sneak documentation it says:

g:sneak#label = 0

    0: Disable |sneak-label-mode|.

    1: Enable |sneak-label-mode| if the Vim |+conceal| feature is available.

I'm on macOS and was using Apple's default Vim version. Apple's default Vim isn't complied with the +conceal feature. I used vim --version to confirm this.

Guided by that SO thread, I installed vim from homebrew:

brew install vim

After a restart of the shell, vim --version now showed the +conceal feature.

And sneak's label-mode works!

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.