0

I facing a strange issue, it might be common but I could not find any solution so asking here.

When I'm opening a python file using vim editor, it is auto-hiding many lines in the script. I found that I can manually go to these hidden lines and press enter which shows those lines. An image of the problem is attached so it is clear what the actual problem I'm facing is. problem How can I go about fixing this? I tried with other editors and this problem is not reflected there. I'm used to vim so want to know what is creating this problem. Thanks in advance.

1 Answer 1

3

These are called folds. See :help folds for details.

In your case, I would either

  • :set nofoldenable in your vimrc if you want to start with folds disabled;
  • zi to toggle folds;
  • or, learn to navigate and use folds (like zj, ]z, za, zr, zf, etc.)
1
  • thanks a lot, I made the change in vimrc file Jan 27, 2022 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.