0

I am trying to set up neovim on my mac.

Using iterm2 and having installed nvim through homebrew. When I launch nvim from my fish shell, it immediately shows

112 q112 q

on the last line.

This does not happen when I use the Apple terminal program. TERM is set to xterm. I have tried xterm-256color which does not fix the problem.

FYI: I have reset all my .vimrc type configuration files, i.e. moved them to a save place.

3
  • 2
    Have you tried How to debug my vimrc?
    – D. Ben Knoble
    Jan 3 at 13:53
  • Welcome to Vi and Vim!
    – filbranden
    Jan 3 at 18:09
  • I am certain it is not a vimrc issue. It is no longer evaluated, i.e. I am running stock neovim on mac installed with homebrew together with iterm2. Somehow, neovim must be interacting with iterm2 in a bad way. Jan 5 at 10:21
2

This is embarrassing.

My problem was a Mac problem. I had a very old version of iterm2 lying around in some "stuff" directory. I was launching it with Command-Space iterm which pointed to the old version instead of the new.

I have removed the old version. With the new version of iterm2, neovim works fine. It would still be interesting to know why neovim fails and vim doesn't but I am happy with how it works now.

Cheers

Holger

1
  • "Neovim fails and vim doesn't": vim as a project is far more concerned about backwards compatibility than neovim. It's entirely possible that some very old code in vim was ripped out in neovim, and it just so happened to overlap with what happened here.
    – D. Ben Knoble
    Jan 5 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.