0

I am using gVim on Windows, and when I enter insert mode for the first time on a fresh document I am hit with a deprecation warning from Python regarding the imp package.

This is quite jarring and I would like to suppress this message in the future. I believe what this post is doing is suppressing all error output however since I am using Vim to edit LaTeX I want to still be able to see errors pop up -- just not these ones regarding Python deprecation.

3
  • Where is the deprecation message coming from? It's likely to be coming from a plug-in that uses Python... Do you have a backtrace that you can share that might show where it's being called from? Or at least a file name/line number of where imp is being imported?
    – filbranden
    Nov 9, 2021 at 1:43
  • 1
    Ultisnips appears to be the problem. It looks like "Line 7" is mentioned, but not sure if that's a Python line or what.
    – Lockjaw
    Nov 9, 2021 at 1:46
  • I think it's possible this is coming from one of the snippets you have set up for UltiSnips... Maybe try a grep -r to find a string such as import imp in your ~/.vim/UltiSnips or equivalent? Do you have plug-ins which ship snippets that might have that specific import that is triggering the deprecation warning? If you can post more about your local config, it would be easier to try to figure it out...
    – filbranden
    Nov 9, 2021 at 18:48

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.