0

I've previously noticed that vim spikes up the CPU usage whenever I scroll up or down at the terminal emulator within the GUI , and when I inspect the process it turns up to be xorg .

I tried to overlook this behavior thinking it might have something to do with the gruvbox color scheme (that it's an intensive colorscheme in terms of rendering for my integrated GPU .

But when I tried to use the AutoComplPop plugin for mere automatic word completion, I was prompted with the same issue of slow word suggestion at the GUI, but quite acceptable at the textual shell session when switching to it.

I can't really tell whether that has to do with vim itself, or the Xorg window manager or even the hardware with such demanding plugins .

In attempt to narrow down the cause of the problem, I

  • switched the window manager to awesome.
  • switched to another terminal emulator.
  • used neovim with the same settings.

Still all of the aforementioned options resulted in the same spike in CPU usage and consequent decline in performance .

4
  • @BLayer yes and i even tried switching to other terminal emulator , and still having an instant CPU spike whenever i start typing with autosuggestion or scrolling .
    – polendina
    Sep 26, 2021 at 7:46
  • There's really not enough information here to answer this with any certainty...though "Vim itself" can be pretty much ruled out.
    – B Layer
    Sep 26, 2021 at 7:47
  • @BLayer what type of additional should i include about my current environment
    – polendina
    Sep 26, 2021 at 7:49
  • It's more that you'll need to narrow it down yourself to plugins, X or hardware. That's not something anyone else can do.
    – B Layer
    Sep 26, 2021 at 7:51

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.