5

Repost from Stackoverflow; I read a comment which directed me here saying it would be more helpful.

Just set up nvim; unfortunately, the following error is plaguing the setup. Whenever I try to install or change plugins or use Vimtex, it will throw the same error message just about everywhere: /usr/bin/bash: /s: No such file or directory. Similar error occurs when I use :checkhealth; the exact error message is below:

## terminal
  - ERROR: command failed: infocmp -L
    /usr/bin/bash: /s: No such file or directory

Additionally, I am using Windows, and here is my config file (switched to a minimal config to see if things would change, but the issue still persists):

set backspace=2         " backspace in insert mode works like normal editor
syntax on               " syntax highlighting
filetype indent on      " activates indenting for files
set autoindent          " auto indenting
set number              " line numbers
colorscheme desert      " colorscheme desert
set nobackup            " get rid of anoying ~file
filetype plugin indent on
" show existing tab with 4 spaces width
set tabstop=4
" when indenting with '>', use 4 spaces width
set shiftwidth=4
" On pressing tab, insert 4 spaces
set expandtab

Does anyone know what is causing the error and how to fix it? Would greatly appreciate it!

7
  • What system are you using? Windows? Linux? macOS? Do you have a nvim configuration file? What does it look like? Sep 21, 2021 at 0:57
  • 1
    Using Windows, and using a minimal nvim config; I will add it into my post.
    – Revise
    Sep 21, 2021 at 1:09
  • Cheers; I don't have any experience running (Neo)Vim on Windows I'm afraid, so I'm not entirely sure. I did find this on the issue tracker though: github.com/neovim/neovim/issues/14605 Sep 21, 2021 at 1:49
  • Are you using cygwin or msys or something similar that comes with a bash? Sep 21, 2021 at 6:28
  • 2
    looks like the given issue mentioned by @MartinTournoij in that case. You may want to explicitly configure your shell related options in that case. That may or may not work. Sep 21, 2021 at 10:38

1 Answer 1

2

On windows, by default shell=cmd.exe and shellcmdflag=/s /c. Most probably somewhere in your config you set shell=bash, but did not adjust shellcmdflag. Set shellcmdflag when you adjust the shell.

if isexecutable('/usr/bin/bash')
     set shell=bash
     set shellcmdflag=-c
endif

There are also other shell* variables you have to modify. See How can neovim on Windows be configured to use gitbash as the shell without breaking temp files?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.