0

I am using Vim in cygwin in a Windows machine. I have installed vundle. When I type :PluginInstall in vim from cmd, it works perfectly fine, but when I do the same with vim in cygwin, it doesn't work. What is happening? How can I fix it?
The output of :scriptnames is

1: C:\Program Files (x86)\Vim\_vimrc
  2: C:\Program Files (x86)\Vim\vim82\vimrc_example.vim
  3: C:\Program Files (x86)\Vim\vim82\defaults.vim
  4: C:\Program Files (x86)\Vim\vim82\filetype.vim
  5: C:\Program Files (x86)\Vim\vim82\ftplugin.vim
  6: C:\Program Files (x86)\Vim\vim82\indent.vim
  7: C:\Program Files (x86)\Vim\vim82\syntax\syntax.vim
  8: C:\Program Files (x86)\Vim\vim82\syntax\synload.vim
  9: C:\Program Files (x86)\Vim\vim82\syntax\syncolor.vim
 10: C:\Program Files (x86)\Vim\vim82\plugin\getscriptPlugin.vim
 11: C:\Program Files (x86)\Vim\vim82\plugin\gzip.vim
 12: C:\Program Files (x86)\Vim\vim82\plugin\logiPat.vim
 13: C:\Program Files (x86)\Vim\vim82\plugin\manpager.vim
 14: C:\Program Files (x86)\Vim\vim82\plugin\matchparen.vim
 15: C:\Program Files (x86)\Vim\vim82\plugin\netrwPlugin.vim
 16: C:\Program Files (x86)\Vim\vim82\plugin\rrhelper.vim
 17: C:\Program Files (x86)\Vim\vim82\plugin\spellfile.vim
 18: C:\Program Files (x86)\Vim\vim82\plugin\tarPlugin.vim
 19: C:\Program Files (x86)\Vim\vim82\plugin\tohtml.vim
 20: C:\Program Files (x86)\Vim\vim82\plugin\vimballPlugin.vim
 21: C:\Program Files (x86)\Vim\vim82\plugin\zipPlugin.vim
 22: C:\Program Files (x86)\Vim\vim82\pack\dist\opt\matchit\plugin\matchit.vim

5
  • 4
    most likely, you have installed vundle in the wrong location (where cmd vim does find it but cygin vim doesn't). Could be an issue of ~/.vim/ (unix) vs ~/vimfiles/ (windows) Sep 14 at 6:13
  • BTW: I forgot to mention. In both environments, please check the output of :scriptnames Sep 14 at 11:57
  • Welcome to Vi and Vim! Please add more details about why you expect the command to work (plugin? How is it installed?) and the output(s) of :scriptnames in an edit.
    – D. Ben Knoble
    Sep 14 at 17:46
  • @D.BenKnoble Ok, I edited it.
    – Euler 2
    Sep 15 at 2:56
  • There is no vundle in the mentioned scriptnames output, that indicates that Vim did not find your vundle. Where did you install it into?. Please also show the :scriptnames command for your cygwin vim. Sep 15 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.