0

I'm having a problem opening certain files (file extensions .sql, .ora) from gvim Version 8.2 using the Windows taskbar icon recent files list.

I have associated the .sql file extension with gvim. No problem if I double click a .sql file from my desktop or from Windows Explorer, it opens the file in gvim. Then I right click my gvim icon in my taskbar and I can see the .sql file I just opened in the Recent files list but when I click it I get a message "The item you selected is unavailable. It might have been moved, renamed, or removed. Do you want to remove it from the list?" Of course, the file is still there and I can still open it, but not from the Recent files list. This also happens for files with a .ora extension. Other files with .txt, .sc, .c, and so on work fine (I can see and open them in the Recent list). I've looked in my .viminfo file and see the recent files listed, including the .sql files.

Picture Example

On a different computer running gvim 8.0 on Windows 10, the .sql files work fine.

Any help out there?

Thanks,

Greg H.

2
  • 1
    I think files on these "recent" lists are found in C:\Users\{USERNAME}\AppData\Roaming\Microsoft\Windows\Recent. You could start by looking there to see if the files are there or if anything looks out of the ordinary with them.
    – B Layer
    Sep 11, 2021 at 1:13
  • Thanks for the reply, @BLayer. I checked there and all looks in order. I can click on any of the shortcuts in that Recent Items folder, and the files open with the appropriate app. Opening from Task Bar icon works fine from all other apps (MS Word, Excel, Adobe Reader, and so on); It's only a problem with the .sql and .ora file extensions and only in gvim. I can even open the same .sql file with Notepad, then use the Notepad taskbar icon recent list and it opens fine.
    – Greg H.
    Sep 21, 2021 at 17:12

1 Answer 1

0

I figured it out. Open "Local Group Policy Editor" in Windows 10.

Hold WinOS + R -> type "gpedit.msc" -> User Configuration -> Administrative Templates -> Start Menu and Taskbar

Enable "Do not keep history of recently opened documents" and RESTART your pc for changes to take effect.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.