4

Can anyone can help me, my vim always shows the cursorline, like this:

14 lines of underlined text

I have set nocursorline in the ~/.vimrc, but it has no effect.

vim version is: 7.4.622

VIM Version 7.4.622

vim is run on OSX 10.10.3, how to remove the white line.

  • This doesn't look like the cursorline. It's probably something in your vimrc file. See: How do I debug my vimrc file?. – Martin Tournoij May 20 '15 at 11:15
  • 1
    I've seen something similar in the past. I never got to the root cause of it, but I'm pretty sure it was related to a font problem, not to Vim. – lcd047 May 20 '15 at 11:25
  • @lcd047 Thanks for your hint. I change my font size from 18 to 19, and it works. I agree that it's a font problem. – lutaoact May 21 '15 at 2:25
  • @lutaoact maybe you could answer your own question so as it doesn't stay unanswered :) – statox May 26 '15 at 18:19
2

Maybe it's font problem, not vim. I change my font size from 18 to 19, and it works. You can make it as what I have done. I didn't change the font of vim, I just change the font size of terminal.

| improve this answer | |
  • 2
    To be more useful to other people you could also indicate how you changed the size of your font ;) If I remember well on gVim and MacVim it is with the option guifont. – statox May 28 '15 at 9:51
0

I had the same issue on my OS X terminal on both vim and neovim. Scrolling up showed the cursor lines on all the lines I had moved up. Through a little bit of trial and error, I narrowed it down to the following lines

" highlight current line
set cul                                                                                                                                                     
" adjust color
highlight CursorLine ctermbg=LightBlue cterm=None term=None
set bg=dark

Moving the 'bg=dark' line above the cursorline configuration fixed it for me.

set bg=dark

" highlight current line
set cul                                                                                                                                                     
" adjust color
highlight CursorLine ctermbg=LightBlue cterm=None term=None
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.