1

When activating the spellchecker (with :set spell spelllang=en_us for example), all incorrect words are highlighted. I'd prefer if they'd not be highlighted, but the spell checker to continue to work (e.g. pressing ]s would still take you to the next mistake).

Is there a way to disable only the highlight, without disabling the spellchecker?

2

Do :filter Spell highlight to see the list of highlight groups related to spell checking. To disable highlighting for a group, for example SpellBad, do

:highlight clear SpellBad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.