0

I can successfully run :sp *filename* several times per vim session, but after a seemingly-random number of splits (5-10) all future splits will no longer have syntax highlighting until I fully quit vim in that terminal. Can be quite annoying as I will have to remember all the files I have open in that session before restarting vim.

To clarify, I am not splitting the current screen between 5-10 files; I am using :sp a few times, :q to close some windows, :sp again, etc. When syntax highlighting starts to fail I might only have 2 or 3 files currently split.

Using :e to reload does not help this issue.

I have a pretty simple .vimrc:

autocmd BufNewFile,BufRead *.svp,*.svh,*.sv,*.v,*.vh so ~/.vim/syntax/verilog_systemverilog.vim                                                                                                                    
syntax enable
se ic              
set tabstop=4 shiftwidth=4 expandtab
set splitbelow 
set splitright 
set mouse=a           
set textwidth=0
set wrapmargin=0
set laststatus=2
set number    
set wildmenu   
set cursorline 
set cursorcolumn
nnoremap J gJ
set background=light
colorscheme solarized
4
  • See if bumping up 'redrawtime' helps.
    – B Layer
    Aug 2, 2021 at 16:27
  • Good suggestion, what is the default for this value as I have never used it before?
    – squarebase
    Aug 2, 2021 at 16:35
  • The default value is in the help page. :h 'rdt' (And surely what your current setting is if you've never used it before.)
    – B Layer
    Aug 2, 2021 at 16:53
  • do you open those svp, svh, sv, etc verilog files? If so what is in verilog_systemverilog.vim?
    – Maxim Kim
    Aug 2, 2021 at 19:36

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.